Symptom
Appointments are synchronized with the wrong folder.
Environment
SAP Cloud for Customer client-side Outlook add-in
Reproducing the Issue
Two accounts are defined in Outlook:
- Account A is the main e-mail account with the Office 365 License, for example abc@xyz.com ('abc' equals the name of an individual, 'xyz' equals a company name.)
- Account B is the secondary account which should be synchronized with SAP Cloud for Customer, for example jobs@xyz.eu
In the add-in Options, Account B is set as the Default Folder for the synchronization. Account B is also used as an e-mail address for the business user in the SAP Cloud for Customer application. The customer expects the synchronization to be done for Account B.
- An appointment is created in the calendar of Account B.
- This appointment is synchronized with SAP Cloud for Customer via the Outlook add-in.
- As soon as the synchronization is finished, the add-in has created a new meeting in the calendar of Account A, which is synchronized from now on.
- The initial appointment in Account B is not synchronized anymore.
Cause
The change of the folder selection within the Options work for the synchronization of contacts but not for appointments.
Resolution
This behavior is as per design.
Keywords
outlook, add-in, client-side, synchronization, folder, appointments , KBA , LOD-CRM-GW-OUT , Outlook , Problem