Symptom
When creating or updating some workforce person data using the API WORKFORCEPERSONMASTERDATAREPLI, the following error message appears:
<LogItem><TypeID>211(BF00)</TypeID><SeverityCode>E</SeverityCode><Note>Bank XX XXXX does not exist</Note></LogItem>
<LogItem><TypeID>022(ECPAO_IN_PROCESSING)</TypeID><SeverityCode>E</SeverityCode><Note>Pernr XXXXXXXX: Infotype 0009, subtype 2 with error</Note></LogItem>
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Configure the Communication Arrangement SAP_COM_0301.
- Use the API WORKFORCEPERSONMASTERDATAREPLI to upload the HR master data.
- Specify the bank account details in the WorkAgreementBankAccountInformation section.
- Post the API.
- Use the Overview Message Monitoring app to view the response.
Cause
The bank data is not maintained correctly in the system.
Resolution
Maintain all the bank information used in the workforce person master data correctly in the Manage Banks app.
Note: If you see the following error in the response: <Note>Enter the bank key</Note>, you have to add the <Bank> tag in the payload, taking into account that the Bank information in that section has to be configured in the same tile, Manage Banks.
See Also
Keywords
bank, enter the bank key, WORKFORCEPERSONMASTERDATAREPLI, Replicating Basic Master Data for Workforce from External HR Systems, API, workforce , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , How To