SAP Knowledge Base Article - Public

2852157 - Error 'The material entered is same as the current material. Enter a different replacement material" when using the App 'Material Where Used List for BOMs' ( IDF2214 )

Symptom

  • A popup occurs with "The material entered is same as the current material. Enter a different replacement material" when using the App  'Material Where Used List for BOMs' ( IDF2214 ) 
  • Unable to update Quantity of a component in a BOM ( Bill of Material ) using the "Replace Material" button

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"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental"

Environment

  • Bill of Material
  • SAP S/4HANA, cloud edition

Reproducing the Issue

  1. Open the App 'Material Where Used List for BOMs'
  2. Input a Component 
  3. Press 'Go' button
  4. highlight an entry for which you wish to update
  5. Press the Button "Replace Material"
  6. Popup for "Replace Material" appears
  7. Input the Replacement Material as the current Material
  8. input a new Replacement Quantity 
  9. press ok

Cause

System works as Designed.

The feature  "Replace Material" is intended to update a Component in a BOM with a New Component

Resolution

Please consider using the API API_BILL_OF_MATERIAL_SRV if you wish to mass update Components of a BOM

Keywords

KBA , PLM-FIO-BOM , Fiori UI for Material BOM , LO-MD-BOM , Bills of Material , PLM-FIO-BOM-2CL , Fiori UI for Material BOM (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions