SAP Knowledge Base Article - Public

2852917 - Payment Terms not reset in Create Supplier Invoice

Symptom

When creating a Supplier Invoice via the APP 'Create Supplier Invoice' a user enters a Supplier and then later changes that Supplier to another. In doing so the Payment terms of the original Supplier remain, they are not re-determined.

Environment

SAP S/4HANA Cloud All versions

Reproducing the Issue

  1. Open App 'Create Supplier invoice'. 
  2. Enter all required header data including the Supplier. 
  3. Add the line item data.
  4. Now change the Supplier to a different Supplier with different Payment Terms. 
  5. Save the document.

* The Payment Terms in the Supplier invoice are those of the first Supplier entered.

Cause

The functionality regarding the Payment Term determination is outlined in note 322430. This applies to the Advanced webgui tile (MIRO) and also to the APP 'Create Supplier Invoice'. 
Once the Payment Terms have been derived by the system they are no longer changed automatically.

Resolution

If a user changes the Payment terms or the Supplier while creating a Supplier Invoice they MUST check the payment terms and reset them manually if required.

Keywords

ZTERM, OBB8, T052, refresh, payment terms, FI_TERMS_OF_PAYMENT_PROPOSE, CL_FDC_ACCDOC_CHK_AND_DET_ACCT. , KBA , MM-FIO-IV , Fiori UI for Invoice Verification , MM-IV-LIV , Logistics Invoice Verification , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions