SAP Knowledge Base Article - Public

2852995 - Benefits - Start a claim button not showing

Symptom

Start a claim- button not showing for some users

**Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central: Global Benefits

Reproducing the Issue

Start a claim button not showing up for few users, however, even for peers it shows denoting as not a generic issue but data issue with specific user:

2852995-1.jpg

Cause

Benefit entitlement amount is set to invalid values (only -1,0 and positive numbers are accepted in Benefit.entitlementAmount).

  • If the benefit eligiblity rule is setting Benefit.entitlementAmount to negative values other than -1, then the issue occurs.
  • Also in benefit claim accoumulation record, if the remaining amount is set to invalid negative value like below:

2852995-3.jpg

  • And if benefit employee claim is imported with invalid negative entitlement values in benefit employee claim object as below:

2852995-2.jpg

Resolution

Correct the values mentioned above to be non negative values (except -1, as it is accepted for unlimited benefit). Make sure that the entitlement rule is not setting enititlement amount to invalid values as well.

Keywords

start a claim, claim button missing, benefit claim button. , KBA , LOD-SF-EC-GBF , Global Benefits , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HXM Core all versions