Symptom
Your user has restricted access for some objects (for example: tickets, opportunities, sales quotes). However, you see information (such as account, territory, owner, etc.) for these objects in the relevant OWL view (i.e. Sales Quotes view). But when opening the objects (i.e. sales quotes), none of the information is displayed.
Environment
SAP Cloud for Customer
Reproducing the Issue
The following steps are only an example. The same can happen in other work centers.
-
Go to the Sales work center.
-
Go to the Sales Quote view.
RESULT: You see many information (such as account, territory, owner, etc.) in the Sales Quote view. -
Open sales quote ABC (ABC represents the sales quote ID) that this user should not be able to see according to the access restrictions provided.
RESULT: The information inside the sales quote becomes blank because your user is not authorized to see it.
Cause
Your user has the Data Protection and Privacy work center with Personal Data Disclosure and Personal Data Removal views assigned.
The Data Protection and Privacy work center is meant for administrators (who always have full access to the system). Hence, this work center assignment overwrites other restrictions.
Resolution
You can remove the access rights for the Data Protection and Privacy work center if you wish the system to use the access restrictions defined for that user/role for other views (such as tickets, opportunities, etc.).
See Also
Blog Access Control Management: Access restrictions explained – Restriction Rules
Keywords
access rights, access restrictions, tickets, opportunities, sales quotes, sales orders, object, view, Data Protection and Privacy, Personal Data Disclosure, Personal Data Removal, business role , KBA , LOD-LE-CQP , Customer Quote Processing , LOD-CRM-SRP , Service Request Processing , Problem