Symptom
When you save background element after inputting the values, an application error occurs "An application error occurred. Check the console logs for more details.".
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Profile
Reproducing the Issue
- Go to one background portlet, and input some values.
- Save
- Error occurs and the page freezes.
Cause
- The Max. Length of "startDate" and "endDate" are configured wrongly.
- The picklist value has a max-length which exceeds the max-length defined for the field in the data model/BCUI.
Resolution
- Please check the Max. Length of "startDate" and "endDate" fields via BCUI or SDM and set the Max. Length number to at least more than 40.
- Increase the Max. Length number above the assigned values in the picklist.
Keywords
background element, fingerprint=1b61c27a03d1a7b3cf2fd9f903416a5b7e153ac9, Fail to create background: startDate is a required field, file name , KBA , LOD-SF-EP-BGD , Background Elements , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , How To
Product
SAP SuccessFactors HCM Core all versions ; SAP SuccessFactors HCM Suite all versions