Symptom
- Reports connecting to Salesforce fail.
- Unable to create a report of a Salesforce Stored Procedure.
- Able to create and refresh reports based of Salesforce Tables in Crystal Reports.
- When attempting to create, or refresh reports based of Salesforce Stored Procedure in Crystal Reports, it fails with the error:
Database Connector Error:’HY000:[SAP][Salesforce] (120) SOQL_FIRST mode prepare failure:
SOQL error:[SAP][Salesforce] (30) Syntax error or access violation when parsing SOQL.
SQL error: :[SAP][Salesforce] (80) Unknown error received from SOAP response, potentially a problem with user privileges.
[Database Vendor Code: 120 ]’
Environment
- SAP Crystal Reports 2013
- SAP Crystal Reports 2016
- Salesforce
Reproducing the Issue
- In Crystal Reports, open a report based of a Salesforce Reports.
- When refreshing the report, it fails with the error:
Database Connector Error:’HY000:[SAP][Salesforce] (120) SOQL_FIRST mode prepare failure:
SOQL error:[SAP][Salesforce] (30) Syntax error or access violation when parsing SOQL.
SQL error: :[SAP][Salesforce] (80) Unknown error received from SOAP response, potentially a problem with user privileges.
[Database Vendor Code: 120 ]'
Cause
- From the initial investigation, this error only occur when reporting of Salesforce Standard Report, which are seen as Stored Procedure in Crystal Reports, and the Salesforce user was migrated from Salesforce Classic, to Salesforce Lightning.
- The cause is currently under investigation by Development, and has been track under SAP Note 2838248
Resolution
- The cause is currently under investigation by Development.
Keywords
CR, SForce , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed
Product
SAP Crystal Reports 2013 ; SAP Crystal Reports 2016