Symptom
You want to invoice your Service Confirmation Invoice Request, however you see the status as Pending, which you are not allowed to invoice.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Go to the Invoice Requests view.
- Search for ABC (ABC represents the ID of Invoice Request)
- Invoice button is greyed out.
- Status is Pending
You are not able to invoice the document.
Cause
When the Contract or Sales Order is released, the system creates a Contract or Sales Order Invoice Request. This Invoice Request contains the Invoice Schedule dates. Every night, a regular job automatically runs and checks the invoice dates. Three days before the invoice date, the job creates Scheduled Invoice Requests for the scheduled invoice dates.
Note that for schedule type Time and Material, the status Pending is set for Service Confirmation Invoice Requests. Three days before the next invoice schedule date the regular nightly job resets the status Pending to status To Be Invoiced for the Service Confirmation Invoice Requests.
Resolution
In exceptional cases (for example, if you cannot wait for the next job run), a manually intervention to force invoicing is possible:
- In the Sales Order or Contract Invoice Request, select the Edit button, then You can also button, then Create Scheduled Invoice Requests;
- In the Service Confirmation Invoice Request, select the Edit button, then You can also button, then Enable Invoicing.
Keywords
Pending ; Invoice Requests ; Schedule Invoice ; Time and Material , KBA , AP-CI-CIR , Customer Invoice Request , AP-SVO-SO , Service Order , How To