Symptom
Workflow Rules for sending notifications are not working.
Environment
SAP Cloud for Customer
Reproducing the Issue
This issue will happen for all workflow rules, irrelevant of the BO:
-
Go to the Administration work center.
- Go to the Workflow Rules view.
- Select the relevant rule.
Eventhough the rule is active, non of the recipients are receiving email notifications as per the Rule.
Cause
In a non-productive system you can specify whether e-mails and faxes should be sent to real addresses of business partners or to an address used for testing purposes. For this case choose "Send all e-mails/faxes to this address" and maintain a mail.
If no mail address is maintained here, no mails will be sent out.
Resolution
To maintain an address here or to change the settings for business partners to receive the e-mails follow below steps:
-
Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Choose Show: All Open Projects.
- Choose the relevant project.
- Choose Open Activity List.
- Select Fine Tune.
- Search the activity E-Mail and Fax Settings.
- Click Open.
- Select E-Mail and Fax Settings.
- Under E-Mail and Fax Delivery in a Non-Productive System.
- Either select 'Send all e-mails to business partners' or select 'Send all e-mails to this address' and maintain the e-mail address.
- Click Save.
Keywords
E-mail missing; Notification failed; No Output; Email , KBA , LOD-CRM-WKF , Workflow , LOD-LE-CQP , Customer Quote Processing , Problem