Symptom
When the Recruiter forwards an Application Profile of an Internal Candidate, s/he receives a message saying that the operation cannot be performed due to the candidate data privacy regardless the fact the internal privacy options is disabled.
Environment
SAP SucessFactors Recruiting Management - All Versions
Reproducing the Issue
Since the candidate privacy option is not visible in the Candidate Profile or the Application Profile, it won't be possible to follow certain steps to reproduce the issue, but if you can see the candidate information, you may be inside the candidate privacy pool.
Cause
When an external candidate creates the Candidate Profile, s/he chooses the privacy flag, if the external privacy options is enabled, then if the candidate is converted from external to internal, the privacy flag is transferred as well, despite if the privacy options is disabled for internal candidates.
Resolution
This reported behavior has been defined as expected by Product Management team, therefore any improvements and changes would require an enhancement request. All enhancement requests are reviewed by our Product Management team and, if successful, are developed and implemented in a future product release. Please, refer to the next article for more information: 2090228.
If it's important to forward the candidate, an alternative would be to send an adhoc email to ask this candidate to apply to the other job. You can do that via the application page through the 'Contact Candidate' button. Also, it won't be possible to change the privacy flag.
See Also
2773171 - Change the share flag of the candidate - Recruiting Management
2213656 - Candidate Privacy options - Recruiting Management
2090228 - How to Submit Enhancement Requests for SAP SuccessFactors Products
Keywords
Can't Forward Candidate; Share Flag; Privacy Flag; Can't Forward Internal Candidate; Candidate Privacy Options; Cannot Forward; Impossible to Forward; , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem