Symptom
When you are trying to change the account in a Lead(which already have an existing account) using A2X service Manage Leads, C4C system throws the below error
Lead has active account, the active account cannot be changed
Environment
SAP Cloud For Customer
Reproducing the Issue
- Consume the Manager Leads WSDL in the target system
- Call the web service to update the account in the Lead which already have an associated account
- C4C system will return an error statment "Lead has active account, the active account cannot be changed"
Cause
Isseu happening because element PersonContactAllowedCode is passed in the xml which already belongs to the existing account.
Moreover, address element is not being passed in the XML.
Resolution
Kindly pass <Address/> element in the xml while updating the new account.
Do not pass element PersonContactAllowedCode in the xml
Keywords
Manage Leads, C4C Integration , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem