SAP Knowledge Base Article - Public

2856564 - Performance Management Error: Invalid competency ID is found in one of your competency sections. Please open the file and verify the competency exists in the system.

Symptom

When trying to upload a performance form template that contains hard-coded competencies, receive an error:

Invalid competency ID is found in one of your competency sections. Please open the file and verify the competency exists in the system.

Environment

  • SAP SuccessFactors Performance Management
  • SAP SuccessFactors Center of Capabilities
  • SAP SuccessFactors Job Description Manager
  • SAP SuccessFactors Job Profile Builder

Reproducing the Issue

  1. Log into Provisioning
  2. Select the company
  3. Navigate to Form Template Administration
  4. Select the performance form template
  5. Select Update by Upload
  6. Select file > Upload Form Template
  7. Receive error

Cause

  • A performance form template with hard coded competencies was loaded from another instance 
  • The competency has no label added under the language that matches the form template language
  • Competency was deleted from Provisioning and then saved from Center of Capabilities

Resolution

I. A performance form template with hard coded competencies was loaded from another instance 

Each time a new competency is loaded/created in the instance, it will get a unique ID (not to be confused with GUID) specific to that instance. The system assigns these IDs in a sequence, and the sequencing may be different in each instance. If a template is loaded from instance A to instance B, instance B will not be able to identify the competency ID in the template.

II. The competency has no label added under the language that matches the form template language

When using multiple languages, it's common for administrators to forget to physically add content for each language that exists and will be used by users. Make sure for every language enabled, content for the language is also translated and entered. Ensure to map the new language to the existing competency GUID when using a multi-lingual form. Some clients accidentally load the new language with a GUID that is not linked to the default language (usually English).

Follow the steps in Using Center of Capabilities - Adding Translations for Capabilities Library Entities

III. Competency was deleted from Provisioning and then saved from Center of Capabilities

As customers go through the JDM to JPB migration, sometimes competencies will need to be deleted from Provisioning and then recreated in Center of Capabilities. The system will assign a new competency ID once a competency has been saved in Center of Capabilities. The competency ID will need to be updated in any performance form templates with hard coded competencies to resolve the issue.

You can reach out to your certified partner if you have one, or look for one using 2149831 - SAP Professional Services / SAP Certified Partner / SAP Account Management Team [SuccessFactors Cloud] to correct this.

See Also

 3237239 - Some Competencies Not Displaying When Adding Custom Competency from Manage Templates - Performance Management

Keywords

Success Factors, SF, Performance, PM, Invalid Competency id configured in the Competency section, Invalid competency ID is found in one of your competency sections, error, upload template, invalid competency ID
, KBA , LOD-SF-PM-FAM , Competencies Behaviors Families and Roles , LOD-SF-TIH-JDM , Job Description Manager , LOD-SF-PM-FRM , Forms & Templates , LOD-SF-TIH-COC , Center of Capabilities , LOD-SF-TIH-JPB-MIG , Migration to Job Profile Builder , Problem

Product

SAP SuccessFactors Performance & Goals all versions