SAP Knowledge Base Article - Public

2857195 - "The recovered or restarted job is cancelled as it might fetch or insert duplicate records" error - Integration Center

Symptom

A scheduled Integration Center (IC) job sporadically fails with the error message below:

"The recovered or restarted job is canceled as it might fetch or insert duplicate records"

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Create an IC job;
  2. Set a scheduling;
  3. Let it runs as scheduled;
  4. See the error message;

Cause

This error is primarily generated by the Job Scheduler Service (Execution Framework feature), which is used by Integration Center jobs and also other scheduled jobs during the time where it should determine what job needs to be executed within the server.

There are two possible causes for the error:

  1. An inconsistency occurs due to some major change in the server itself (e.g., a maintenance activity), which makes the job to be set "on hold". Integration Center then cancels the job to avoid duplications and the error message is shown. This is an expected behavior by Integration Center. The job will fail if its scheduled time ends up conflicting with some other change in the server (refer to this chapter from Integration Center guide).

  2. Job is encountering difficulties in building the SQL query due to a Time-Based filter implemented by the customer. Time-Based filter will be automatically applied to all the navigated entities and as a result of the customer mapping fields to a large number of entities, the job is getting stuck while constructing the complex query. Additionally, noticed that the data is not being retrieved in the preview due to this issue.

Resolution

For cause 1:

The current workaround solution for that is running manually the failed integration by clicking in "Run Now" button.

 

For cause 2:

The recommendation is review the job settings according Integration Center best practices. One option is reduce the number of navigated entities by removing this kind of fields from Configure Fields tab. The other option is set the LastModifiedTime filter under Advanced Filters only for the required entities instead of use Time-Based Filters.

See Also

Integration Center guide

Keywords

ic, successfactors, success factors, sf, sfsf, error, job, provisioning, backend, int, sporadic, intermittent, canceled, temporary, fail, message, "The recovered or restarted job is cancelled as it might fetch or insert duplicate records" , KBA , LOD-SF-INT-INC , Integration Center , LOD-SF-INT , Integrations , Problem

Product

SAP SuccessFactors HCM suite all versions