Symptom
While submitting external requests, users see a different approval process than the one set on global variables under Approval Process Settings.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
-
Login on LMS as one of the affected users;
- Click on external request under the links tile;
- Click at New Request;
- Provide the information for the required fields;
- Click Submit and notice that the steps and level do not look correct.
Cause
An Assignment Profile which the user is part of is assigning a different process.
Resolution
-
Go to the LMS admin view;
- Navigate Users > Users;
- Search for the affected user and open the profile;
- Go to Assignment Profile, under the related section;
- Click on the AP description to open the AP details;
- Navigate to External Requests, under the related section, and observe that the process ID does not match with the one set on the global variables;
- Open the dropdown to leave it empty (which will result on the approval process from the global variables to be assigned as default)
OR
select the approval process you would like to assign for the users on the AP.
Keywords
AP, approval process, lms, sap, external request, external training , KBA , LOD-SF-LMS-TAP , Approvals , Problem
Product
SAP SuccessFactors Learning all versions