Symptom
A Learning user is getting the following error message when accessing courses that have a cost associated:
An application error has occurred. Please try again. If you have further questions or issues regarding this error, please provide the error details below to your support group.
Error message = Request processing failed; nested exception is java.lang.NullPointerException: while trying to invoke the method com.plateausystems.elms.framework.financial.valueobject.ShoppingAccountVOX.getShoppingAccountType() of a null object returned from com.plateausystems.elms.client.javabean.StudentJB.getStudentShoppingAccountVOX(java.lang.String)
Environment
SAP SuccessFactors Learning
Cause
- A user was manually deleted and then reincarnated by the Connector.
- This action removed the shopping account link.
Resolution
- Login into Learning Administration via BizX
- Navigate to People -> Users -> Search for affected user id
- Open user details page and go to Finance tab
- Check if Shopping Account ID is present and enabled
- Open an case with Product Support to check the PH_SHOPPING_ACCT for the Shopping Account ID that was previously associated to the user
- Add the Shopping Account ID, make the user Interal/External as per the proper user categorization and check the "Enable Shopping Account"
- Save the changes
Keywords
LMS, shopping, error, SF, success factors, elearning , KBA , LOD-SF-LMS-COM , Commerce , Problem