Symptom
A Learning user is getting the following error message when accessing courses that have a cost associated:
An application error has occurred. Please try again. If you have further questions or issues regarding this error, please provide the error details below to your support group.
Error message = Request processing failed; nested exception is java.lang.NullPointerException: while trying to invoke the method com.plateausystems.elms.framework.financial.valueobject.ShoppingAccountVOX.getShoppingAccountType() of a null object returned from com.plateausystems.elms.client.javabean.StudentJB.getStudentShoppingAccountVOX(java.lang.String)
Environment
SAP SuccessFactors Learning
Cause
A user was manually deleted and then reincarnated by the connector. This action removed the shopping account link.
Resolution
- Learning Administration > People > Users > Search and access the affected user ID >
- "Finance" tab > Check if the "Shopping Account" field is filled with the ID > And if "Enable Shopping Account" is checked > They should be empty/unchecked >
- Open a case with SAP Support and ask to check the "PH_SHOPPING_ACCT" table for the affected user > It should hold the Shopping Account ID that was previously associated to the user >
- Then, add the ID in the "" field > Set "Shopping Account Type" to Internal/External as per the proper user categorization > And check the "Enable Shopping Account" box >
- Click "Apply Changes".
See Also
Keywords
learning, user, course, item, cost, price, access, open, launch, shopping, error, java.lang.NullPointerException, getShoppingAccountType(), com.plateausystems.elms.framework.financial.valueobject, StudentJB.getStudentShoppingAccountVOX , KBA , LOD-SF-LMS-COM , Commerce , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-USR , User Entity , Problem