Symptom
- The Team Provisioning API /Groups/<Team_ID> returns a 404 error in SAP Analytics Cloud (SAC).
- The issue happens on non-SAP data centers (Cloud Foundry / CF).
Environment
SAP Analytics Cloud (Cloud Foundry / CF)
Reproducing the Issue
- In one POST Client, run GET /api/v1/scim/Groups/<Team_ID>.
- It returns HTTP 404 error.
Cause
- The team is created through SAC UI, which belongs to different namespace (package) rather than SCIM API.
- Whenever trying to access a TEAM, either from scim or from UI, the full TEAM name is sent in the EPMObjectID format (<TYPE::Package::name>) by default.
Resolution
- Option 1 (Recommended): Switch on Ignore Content Namespace For Teams option in System > Administration > System Configuration
=> In this case, it will only use the name to identify the TEAM, and not use the Package (namespace) at all.
=> It also means that as long as the TEAM name is unique in the tenant, there will be no issues. Otherwise, we will display an error saying that there is a duplicate team and one of them needs to be deleted.
=> It will override the “IMPLEMENT_WORKAROUND_FOR_GROUPS” toggle as Option 3 which was introduced in wave 2019.24 to enable SCIP API find the team created manually in SAC. - Option 2: Leverage SCIM 2.0 (/scim2/Groups/<Team_ID>)
=> The ID must be set to a UUID and not a team name (example: "id": "523d31f7-e5a5-453a-b8f0-327c6de333c8")
=> Currently, the UUID cannot be found from SAC UI but only from SCIM2 API.
=> See more detail from help guide. - Option 3 (Not Recommended): Report one incident to SAP Support to reqeust SAC Operation team to set toggle IMPLEMENT_WORKAROUND_FOR_SCIM_GROUPS on.
=> When the toggle is on, SAC will now properly find the team created manually in SAC, and the SCIM API should no longer return the HTTP 404 error.
=> Any groups created by the SCIM API before turning on this toggle will no longer be accessible by the SCIM API and should be deleted using the API before turning on the toggle.
=> Any groups created after the toggle is on will work correctly.
=> It will no longer be possible to change the Content Namespace in the System Configuration, as the workaround requires all teams to have been created with the current content namespace. Teams created with a different content namespace will not be accessible.
See Also
- Making manually created SAP Analytics Cloud teams readable by the SCIM API
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud > Learning > Data Connections
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, Provisoning , KBA , groups api not working in sac quality , error: 404 not found , LOD-ANA-LS , Licensing and Full User Equivalent , Problem
Product
SAP Analytics Cloud 1.0