Symptom
'Initiated For' and 'Entity Effective Date' fields are blank in Manage alerts and notification for some users.
Environment
SAP SuccessFactors Employee Central: Workflows and Alerts
Reproducing the Issue
Go to 'Manage Alerts and Notifications' and some alerts might have 'Initiated For' and 'Entity Effective Date' fields as blank.
Cause
If user's job information effective dated record for which this particular alert was created is deleted, then 'Initiated For' and 'Entity Effective Date' will be blank as related job information record is removed.
Resolution
These alerts can be manually deleted from 'Manage Alerts and Notifications' or it can be left as it is as this will not trigger notification to the user.
Keywords
Alerts, Manage alerts and notification, Initiated For, Entity Effective Date , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , LOD-SF-EC , Employee Central , Problem