SAP Knowledge Base Article - Public

2857895 - Integration Center - No data when running the CalibrationSubjectRank Entity - Calibration

Symptom

Using the CalibrationSubjectRank Entity in Integration Center to pull data about ratings, the output does not return any results or data.

Environment

SAP SuccessFactors Calibration

Reproducing the Issue

  1. Go to Admin Center > Integration Center > My Integrations.
  2. Create > Scheduled Simple Output Integration.
  3. Search CalibrationSubjectRank and click Select. Select desired fields.
  4. Add necessary Filters in the Filter and Sort tab.
  5. Click Configure Fields tab - No preview data showing.
  6. Output CSV is not showing any results.

Cause

Rank column in not enabled in the Bin view of the calibration template.

Resolution

The CalibrationSubjectRank entity will only pull data for Calibration templates that have the option "Enable rank column in bin view" enabled. To enable the rank column option, go to Admin Center > Manage Calibration Templates > Advanced tab. Please note that values will only be pulled when Bin view is used in the calibration template.

See Also

 2712639 - Enable rank column in bin view- What data does the rank column associate to?

Keywords

CalibrationSubjectRank, integration center, rank column, bin view , KBA , LOD-SF-CAL-API , Webservices, OData APIs , Problem

Product

SAP SuccessFactors Performance & Goals all versions