Symptom
You are unable to Create From Business Partner in the Partner Contacts work center. When you select an item and you go to More at the top-right corner, then the option Create From Business Partner is missing. You see the following message at the bottom of the screen: No action available.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Partners work center
- Click on Partner Contacts view
- Select a partner contact
- Click on More
Cause
It is the correct system behavior that the option Create From Business Partner in Partner Contacts view of the Partner work center doesn't exist.
- If you use an existing business partner to create an account, competitor, partner, contact, it involves only adding another role to the business partner.
- If you use an existing business partner to create an internal or external employee, it is not trivial. A new Employee ID needs to be provided via external numbering. A new identity may need to be created as well. These processes are complex and error - prone.
Resolution
You can use an existing business partner to create an account, individual customer, competitor, partner, contact, etc. But you can't use an existing business partner to create an employee.
Keywords
Partner work center, convert business partner into partner, assign multiple roles to business partners, button for partner contact missing, not possible to convert the contact into a partner contact, , KBA , LOD-LE-BP-BP , Business Partner , Problem
SAP Knowledge Base Article - Public