Symptom
When opening a sales document e.g. a customer return XYZ (XYZ represents the ID of the return) you get the following error message:
"Item XX: Product ABC not valid; it is not released for use" (XX represents the ID of the line item and ABC represents the ID of the product).
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Returns view.
- Search for return XYZ and open the document.
The following error message occurs:
"Item XX: Product ABC not valid; it is not released for use"
Cause
The most probable cause for this is changes to the master data in the org management which caused the system to not find the necessary data anymore.
Resolution
To be able to get the current data, a dummy change of the involved parties needs to be done.
To do so please follow these steps:
- Go to the Sales Orders work center.
- Go to the Returns view.
- Search for return XYZ and open the document.
- Click the View All button and navigate to the Involved Parties tab.
- Select Sales Unit and click the Remove button.
- Click the Add Row button and reenter the same sales Unit again.
- Click the Save button to save the changes.
Document is now without error and return can be processed further now.
Keywords
Customer Return, not valid; it is not released for use, Retoure, , KBA , AP-CRP-CR , Customer Return , Problem