Symptom
You are experiencing the error message 'No report data available to display; check the selection' when running the standard report 'Daily Average Ticket Backlog by Service Organization (Last 6 months) [CRMSRQHHB_Q0004]'. Additionally, there is no data maintained for the data source 'Ticket Backlog [CRMSRQHHB]', which the report is based on.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Business Analytics work center.
- Go to Design Reports view.
- Search for 'Daily Average Ticket Backlog by Service Organization (Last 6 months)' standard report.
- Open the report.
- Run the report.
- You can see the following message.
'No report data available to display; check the selection'
Cause
The function 'Do you want to enable Historical analysis of service requests?' is not enabled under the scope on the business configuration.
Resolution
You can enable your system to store the historical data of service requests following the steps below:
- Go to Business Configuration.
- Go to Implementation Project.
- Search for First Implementation.
- Click on Edit Project Scope.
- Go to Scoping.
- Expand Service and click Service Request Management.
- Click Next (Tab Review Questions).
- Search for the question Service Request History.
- Check the box for: Do you want to enable Historical analysis of service requests?.
- Save.
Once that is done, then all the tickets that gets newly created would be enabled for historical analysis, and would be available in the report 'Daily Average Ticket Backlog by Service Organization (Last 6 months) ' and in the data source 'Ticket Backlog [CRMSRQHHB]'. Please note storing this information can have a performance impact on your solution if you have a high number of service requests, so the performance impact should be weighed against the need for reporting this information
Keywords
No report data available to display; check the selection, Ticket Backlog, Daily Average Ticket Backlog by Service Organization (Last 6 months) , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-CRM-SRP , Service Request Processing , How To