SAP Knowledge Base Article - Public

2861219 - Error when Trying to Save Data Mashup for Knowledge Base Integration

Symptom

  • You are working with Knowledge Base Integration with MindTouch and is seeing errors when trying to create the Data Mashup.
  • This explanation is also valid for SMS scenarios. Difference is that the Certificates must be taken from the SMS Provider URL, you open it on the browser and follow same steps as described below.

    Image/Data is from SAP internal systems, sample data, or demo systems.  Any resemblance to real data is purely coincidental.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Select the Mashup Authoring view.
  3. Click New and then on Data Mashup.
  4. Fill in all the necessary data (you may refer to the Help Center Article Use Knowledge Base to Resolve Tickets for more information).
  5. When you try to save and activate the mashup, you get the errors: "Preview the result of the mashup before proceeding next"
  6. When you preview it, however, there is another error: "Mashup cannot be displayed. Contact your key user."
    Possible causes:
    • The mashup requires input and no data is available.
    • The connection to the web service provider cannot be established.
    • The web service has encountered a problem.
    • There is an error in the mashup configuration.
    • Credentials are not valid; check the API key of the mashup.
    • The mashup is deactivated.
    • Another possibility is the HTTP 500 error.

Cause

One of the possible causes is that the Certificate for the API is not installed on the Cloud for Customer.

Resolution

  • There are two tasks required to install the Certificate:
    1. Extract it.
    2. Upload it.
  • To extract the certificate you need to:
    1. Open the API URL on the browser. We will use Google Chrome and the SAP standard API - https://sapseod.mindtouch.us/, as example. You need to use your URL API then.
    2. Once it is opened, you need to click the locker icon, like the screen below.
      Mashup KBA 1.jpg
    3. Then, the below screen will open. Click Certificate (Valid) to open the certificate.

      Mashup KBA 2.jpg
    4. Once you click Certificate, the Certificate popup is opened. You need to click Certification Path, then double-click the first level, then Details and then on Copy to File..., and Next.Mashup KBA 3.jpg
    5. On the Certificate Export Wizard, select the Base-64 encoded X.509 (.CER).
      Mashup KBA 4.jpg
    6. Save the file on your computer. It is advised to use the same name as the Certificate, to avoid confusion.

      Mashup KBA 5.jpg

Important: you will need to do this for all Certificate levels.

  • To install the certificate on the machine.
    1. Go to the Administrator work center.
    2. Select the Common Tasks view.
    3. Click Edit Certificate Trust List.
    4. Click Upload.
    5. Click Browse and select the files you saved on the previous steps. (You will need to do it separately for each file, but the order is not important).
    6. Save all files on the system.

Once done, the error on the Mashup save should be resolved.

See Also

 Help Center Article Use Knowledge Base to Resolve Tickets.

Keywords

Certificate, Mashup, Mindtouch, Knowledge Base, Knowledge Base Integration, Mindtouch Integration, Mashup Authoring, Data Mashup, Mashup Web Services, SMS, messaging, short code, gateway, 500, The gateway returned an error while sending the message. HTTP Code 500. , HTTP Code 500, The gateway returned an error while sending the message, Outbound, , KBA , mindtouch , AP-RC-GEN-MSH , Mashups , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions