SAP Knowledge Base Article - Public

2863070 - Using Data Workbench Unable to Mark the Main Address for the Addresses Uploaded to the Accounts

Symptom

Using Data Workbench, uploaded the Account using Data Workbench object Account along with one Address. Require to upload more Addresses to the existing Account. Therefore, used the Data Workbench object Account Addresses and uploaded further addresses. But the Main address is created two times. Instead of updating the missing information like Ship-to, Bill-to Party which are not part of the initial address, the address is created a second time.

Environment

SAP Cloud for Customer

Reproducing the Issue

Upload the Account with its address:

  1. Go to Data Workbench workcenter
  2. Go to Import view
  3. Select the radio button for Individual Object
  4. Go to Upsert tab
  5. Go to Standard Object tab
  6. Search for the Data Workbench object Account
  7. Select Download
  8. Fill data in the fields
  9. Save the file
  10. Select Next and Browse for the file
  11. Select Upload
  12. Choose Next
  13. Select Import
  14. In the Monitor tab, check for the respective Task ID
  15. Upload is successful with status Finished 

Verify the Address of the Account:

  1. Go to Customers work center
  2. Go to Accounts view
  3. Find the Account ID which was uploaded
  4. Go to the Addresses facet
  5. As there was only one Address provided in the Account upload file, the address specified becomes the Main address where the Ship-To and Bill-To become Yes Automatically.

Add more addresses to the Account to include Ship-to, Bill-to Party which are not part of the initial address:

  1. Go to Data Workbench workcenter
  2. Go to Import view
  3. Select the radio button for Individual Object
  4. Go to Upsert tab
  5. Go to Standard Object tab
  6. Search for the Data Workbench object Account Addresses
  7. Select Download
  8. Fill data in the fields 
  9. For the new Address, fill as below:
  10. Ship_To - True
  11. Deafault_Ship_To - True
  12. Bill_To - False
  13. Default_Bill_To - False
  14. Main_Address – False 
  15. Include the first address again, as modification is required for the fields:
  16. Ship_To - False
  17. Deafault_Ship_To - False
  18. Bill_To - True
  19. Default_Bill_To - True
  20. Main_Indicator – True 
  21. Save the file
  22. Select Next and Browse for the file
  23. Select Upload
  24. Choose Next
  25. Select Import
  26. In the Monitor tab, check for the respective Task ID
  27. Upload is successful with status Finished

 The new Address has been added to the existing Account. However, there is a duplicate entry of old address.

Cause

In the Account Addresses template, you added the old address again, with new information for Ship-to, Bill-to Party. That is the reason the old address is duplicated.

Resolution

Initially while uploading the Account into the system with the corresponding Address, the system by default makes this Address as the Main with Ship-To and Bill-To as Yes. Further, while uploading new Account Address, fill the fields of the template appropriately with True and False such that it adjusts with the existing address in the Account. Do not include the old address to this template, to avoid duplicate addresses.

For example, if you want the new Address to be the Ship-to and Main, then fill True in the respective fields. Upon uploading this file in the Import view, it will automatically make the old address False for Ship-to and Main Address, and only the Bill-to Party will be True.

See Also

2660153 - Settings for Account Addresses as Yes/Yes(Standard)/Yes(Automatic)/No

Keywords

Ship-to, Bill-to, Account Addresses, Addresses, Account, Main Address, Main indicator, Main, Data Workbench , KBA , account addresses , main address , addresses , ship-to , bill-to , main indicator , account , data workbench , main , LOD-LE-BP-BP , Business Partner , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions