Symptom
Using Data Workbench, uploaded the Account using Data Workbench object Account along with one Address. Require to upload more Addresses to the existing Account. Therefore, used the Data Workbench object Account Addresses and uploaded further addresses. But the Main address is created two times. Instead of updating the missing information like Ship-to, Bill-to Party which are not part of the initial address, the address is created a second time.
Environment
SAP Cloud for Customer
Reproducing the Issue
Upload the Account with its address:
- Go to Data Workbench workcenter
- Go to Import view
- Select the radio button for Individual Object
- Go to Upsert tab
- Go to Standard Object tab
- Search for the Data Workbench object Account
- Select Download
- Fill data in the fields
- Save the file
- Select Next and Browse for the file
- Select Upload
- Choose Next
- Select Import
- In the Monitor tab, check for the respective Task ID
- Upload is successful with status Finished
Verify the Address of the Account:
- Go to Customers work center
- Go to Accounts view
- Find the Account ID which was uploaded
- Go to the Addresses facet
- As there was only one Address provided in the Account upload file, the address specified becomes the Main address where the Ship-To and Bill-To become Yes Automatically.
Add more addresses to the Account to include Ship-to, Bill-to Party which are not part of the initial address:
- Go to Data Workbench workcenter
- Go to Import view
- Select the radio button for Individual Object
- Go to Upsert tab
- Go to Standard Object tab
- Search for the Data Workbench object Account Addresses
- Select Download
- Fill data in the fields
- For the new Address, fill as below:
- Ship_To - True
- Deafault_Ship_To - True
- Bill_To - False
- Default_Bill_To - False
- Main_Address – False
- Include the first address again, as modification is required for the fields:
- Ship_To - False
- Deafault_Ship_To - False
- Bill_To - True
- Default_Bill_To - True
- Main_Indicator – True
- Save the file
- Select Next and Browse for the file
- Select Upload
- Choose Next
- Select Import
- In the Monitor tab, check for the respective Task ID
- Upload is successful with status Finished
The new Address has been added to the existing Account. However, there is a duplicate entry of old address.
Cause
In the Account Addresses template, you added the old address again, with new information for Ship-to, Bill-to Party. That is the reason the old address is duplicated.
Resolution
Initially while uploading the Account into the system with the corresponding Address, the system by default makes this Address as the Main with Ship-To and Bill-To as Yes. Further, while uploading new Account Address, fill the fields of the template appropriately with True and False such that it adjusts with the existing address in the Account. Do not include the old address to this template, to avoid duplicate addresses.
For example, if you want the new Address to be the Ship-to and Main, then fill True in the respective fields. Upon uploading this file in the Import view, it will automatically make the old address False for Ship-to and Main Address, and only the Bill-to Party will be True.
See Also
Keywords
Ship-to, Bill-to, Account Addresses, Addresses, Account, Main Address, Main indicator, Main, Data Workbench , KBA , account addresses , main address , addresses , ship-to , bill-to , main indicator , account , data workbench , main , LOD-LE-BP-BP , Business Partner , Problem