Symptom
Business Role XYZ has the required work center views in it. When you try to assign the Business Role XYZ to the Business User, the views are not getting assigned, even if the views are available in the Business Role. You see the warning messages.
Example:
Business Role XYZ has below work center view in it:
COD_SALESTARGETPLAN_WCVIEW which is for Sales Target Planning view
When you try to assign the Business Role XYZ to the Business User, the views are not getting assigned, and system throws the below warnings:
Rule 02 - Managed Sales Units for View COD_SALESTARGETPLAN_WCVIEW in Business Role XYZ determined no restrictions
View COD_SALESTARGETPLAN_WCVIEW can't be assigned since no restrictions could be determined
Environment
SAP Cloud for Customer
Reproducing the Issue
To create a Business Role:
- Go to Administrator workcenter
- Go to General Settings view
- Go to Business Roles view
- Select New to create the Business Role XYZ (where XYZ represents the Business Role)
- Assign the required workcenter views in it
- Save the Business Role
- Set it to Active status
To assign the Business Role XYZ to the Business User
- Go to Administrator work center
- Go Business Users view
- Search for Business User
- Select Edit and choose Access Rights
- In Business Role Assignment tab, assign the Business Role: XYZ
- You observe the mentioned warnings
Cause
Work center assignment may not happen if Restriction Rule does not yield any data. In the above example, the Business Role has been set to Restricted Access for Sales Target Plan based on Rule 02 - Managed Sales Units. Since the Business User is not a manager of any Sales Unit in the system, the work center cannot be assigned to the Business User.
Resolution
Create a Sales Unit where the Business User is a manager or remove the Restriction. This should give the access to the work center view.
Keywords
Managed Sales Units, Access Rights, Business User, Business Role, Determined no restrictions, No restrictions could be determined, Restricted Access , KBA , business role , no restrictions could be determined , rule 02 - managed sales units for view , managed sales units , business user , restricted access , determined no restrictions , access rights , SRD-CC-IAM , Identity & Access Management , Problem