Symptom
Business Role XYZ has the required work center views in it. When you try to assign the Business Role XYZ to the Business User, the views are not getting assigned, even if the views are available in the Business Role. You see the warning messages.
Example:
Business Role XYZ has below work center views in it:
COD_WORK_TICKET_WCVIEW which is for Work Tickets view
SEOD_TICKETMD_SADL_WCVIEW which is for Tickets view
When you try to assign the Business Role XYZ to the Business User, the views are not getting assigned, and system throws the below warnings:
Rule 01 - Service Units of Employee for View COD_WORK_TICKET_WCVIEW in Business Role XYZ determined no restrictions
Rule 01 - Service Units of Employee for View SEOD_TICKETMD_SADL_WCVIEW in Business Role XYZ determined no restrictions
View COD_WORK_TICKET_WCVIEW can't be assigned since no restrictions could be determined
View SEOD_TICKETMD_SADL_WCVIEW can't be assigned since no restrictions could be determined
Environment
SAP Cloud for Customer
Reproducing the Issue
To create a Business Role:
- Go to Administrator workcenter
- Go to General Settings view
- Go to Business Roles view
- Select New to create the Business Role XYZ (where XYZ represents the Business Role)
- Assign the required workcenter views in it
- Save the Business Role
- Set it to Active status
To assign the Business Role XYZ to the Business User
- Go to Administrator work center
- Go Business Users view
- Search for Business User
- Select Edit and choose Access Rights
- In Business Role Assignment tab, assign the Business Role: XYZ
- You observe the mentioned warnings
Cause
User's validity in the Org Unit: 9999 was only until DD.MM.YYYY which is a date in the past.
where 9999 represents the Organizational Unit
Resolution
Extend the user's validity to a future date DD1.MM1.YYYY1 in the Organizational Unit. Thereafter, assign the Business Role: XYZ to the Business User. You will be able to see that the work center views are assigned to the Business User.
Keywords
Service Units of Employee, Access Rights, Business User, Business Role, Determined no restrictions, No restrictions could be determined, Organizational Unit, Org unit , KBA , determined no restrictions , business role , organizational unit , access rights , org unit , service units of employee , business user , no restrictions could be determined , rule 01 - service units of employee , SRD-CC-IAM , Identity & Access Management , Problem