Symptom
We have created a business rule to check duplicates using look up function but the rule works some time and other times it allows duplicate values to be saved. For example: Below is the sample rule where the rule is checking duplicate bill number when benefit employee claim is submitted.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central: Global Benefits
- SAP SuccessFactors Employee Central: Business Rules
Reproducing the Issue
- Create a business rule to check duplicates using lookup function
- Try to create new claim using same value from existing claim and system allows to save the value
Cause
Currently lookup function just checks the top of stack record so look up function will only fetch one value which is at top and validates it with current data hence it does not check for all existing claims.
Resolution
We do not have any loop over functionality to achieve the requirement. We request you to raise an enhancement to have this functionality in future as per KBA 2088892.
See Also
PAYMENT INFORMATION DUPLICATE CHECK FOR ACCOUNT NUMBER
The switch 'Enable Bank Account Validations' in Company System and Logo Settings does not enable duplicate account number check. When this feature is enabled, the system checks if the entered account number is valid as per the country-specific validation configured for payment info.
If you are checking the duplicates in the Payment Information Bank Details such as Account Number, please check this blog
Successfactors Employee Central Deep Validations | SAP Blogs
Keywords
Rule, lookup, duplicate check, employee claim, Payment Information, Account Number Duplicate Check, Lookup Bank Details, , KBA , LOD-SF-EC-GBF , Global Benefits , LOD-SF-EC-RUL , DO NOT USE - Business Rules & Event Derivation , LOD-SF-EC-PAY , Payment Information (Bank Information) , Product Enhancement