Symptom
On reviewing a terminated employees Job Hisotry data records exist after the termination record. This can have impacts on integrations with other systems and the employee's status.
Environment
Employee Central
Reproducing the Issue
-
Navigate to a Terminated Users profile.
- Go to the user Job History.
- The Termination Record is visible but there are effective records with data changes maintained after the Termination record which are not Rehire records.
Cause
This can be caused by one of two things:
Job History Changes:
Any user who has Insert New Record Permissions in Job History for the Terminated user can manually enter records in the users history which are effective after the user Termination Date.
There is currently no method to stop users from altering a Terminated User History as described above. The Job History UI is considered an Admin UI and users with Insert New Record permission should be instructed to not alter a Terminated Users Job Hisroty in such a way.
Please see the following KBA for further information on this topic: 2724366 - Employee History can be Changed for Terminated Employee
Data Records Existing before the Termination was created:
If a user is Terminated on a date prior to that of records in their Job History, the Termination record will be created on the desired date but the future records will not be delimited. They will remain in the users Job History.
On Termination of an employee the user carrying out the Termination should review the employee JobHistory and correct any data issues which may occur due to the insertion of the Termination record.
Resolution
There are currently no methods to prevent the above actions. Any change to this logic would be considered an enhancement request.
Keywords
termination, integration, job history, fail , KBA , LOD-SF-EC-JOB , Job Information , LOD-SF-INT , Integrations , LOD-SF-EC-EMP , Employment Information (Employment Details) , Problem