Symptom
The Internal to External Candidate Deconversion job is failing in provisioning. You will see the error message "No Contact e-mail or User e-mail details found for a candidate" in the details of the scheduled job.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Make the internal candidate inactive in the system.
- Run the Internal to External Deconversion job via Manage Schedule Jobs in Provisioning.
- In the job details, you will receive information of the internal candidates who this job failed for.
Cause
The reason is that the internal candidate has no contact e-mail configured in their internal candidate profile.
Resolution
- You'll need to update the contact e-mail for these candidates via an OData API.
- After this, you'll need to calculate how long this candidate has been made inactive. Then, via Manage Recruiting Settings-->Internal to External Candidate Profile Conversion, configure this value in the weeks column.
- Run the job again in provisioning to deconvert the candidate in question.
Keywords
Manage Recruiting Settings, Internal Candidate. , KBA , LOD-SF-RCM-CAP , Candidate Profiles , Problem
Product
SAP SuccessFactors Recruiting all versions