Symptom
An application error message is received when trying to add a new time/date format to a locale.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Learning Administration > References > Manage Labels > Locales >
- Select the desired locale > Edit >
- Go to the "Date Patterns" or the "Time Patterns" tab >
- Try to change the current default value by adding a new pattern or picking one of the patterns already listed >
- The system will throw an application error message:
- An application error has occurred. Please try again.
Cause
The issue is caused because the date pattern and time pattern related to the locale ID have the last updated user as null in the database.
Resolution
- Go to References > Manage Labels > Locales >
- Search for the desired locale >
- Click the edit button >
- Go to the "Time Patterns" tab >
- Click "Apply Changes" without modifying anything >
- Go to the "Date Patterns" tab >
- Click "Apply Changes" without modifying anything.
After following the above-mentioned steps, try to add a new date pattern or time pattern to the desired locale. There should not be any issue while adding the same.
Keywords
error, add, adding, default, locale, unsunsetDefaultActiveLocaleDateFormatPatternForCurrentPatternType, application, time, date, pattern , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , Problem