Symptom
A business rule has been configured on the job application template. The configuration is correct but the rule does not trigger.
Environment
SAP SuccessFactors Recruiting Management
Cause
This is because Mobile Apply is enabled in Admin Center -> Manage Recruiting Sites. Currently, rules on candidate facing job applications cannot be used when Mobile Apply is enabled.
Resolution
Rules will still work for Recruiters working on applications in the system, but not for candidates on the external career site. If Mobile Apply is disabled, the job application rules will work as expected for candidates.
Product Management is working on having job application rules work with Mobile Apply.
To vote and review the Enhancment Request open to allow rules to work Mobile Apply in the above scenario please click on the link below:
Customer Influence: [Rules] - Support Business Rules with Mobile Apply
See Also
Supported System and Custom Fields for Job Application Business Rules - Implementation Guide
Keywords
Business rule, job application, API, trigger , KBA , LOD-SF-RCM-RUL , Recruiting Rule Issues with MDF Platform , LOD-SF-RCM-APP , Applicants and Job Applications , LOD-SF-RCM-MOB , Mobile Interface, Mobile Apply , Problem