Symptom
- Unable to initiate Onboarding from RCM
- Error received ErrorCode - 500; ErrorMessage- Can't update AssignedTo column
Environment
SAP Successfactors Onboarding 1.0
Reproducing the Issue
- In Job Req
- Click Take Action
- Click Initiate Onboarding
- Error Received "Unable to initiate onboarding process. [ErrorCode - 500; ErrorMessage- Can't update AssignedTo column.]"
Cause
Comma exists in a username being sent from RCM to ONB
Resolution
- Navigate to Mapped Data Review Tool
- Select Mapped Data Review for Recruiting to Onboarding
- Search for applicant
- Review the data being sent for each named user type for example Hiring manager
- Comma existed for ID being sent for Hiring Manager
- Navigate to Onboarding
- Select Settings
- Select Data Dictionary
- Search for Hiring Manager Key
- Ensure that Data Type is User and not String
- Once updated to User type
- Try to initiate Onboarding again from the job req
Keywords
AssignedTo column, username, comma, Unable to initiate onboarding process, ErrorCode 500, AssignedTo column, SF, Success Factors, OBD, ONB , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem
Product
SAP SuccessFactors Onboarding all versions ; SAP SuccessFactors Recruiting all versions