SAP Knowledge Base Article - Public

2867784 - Error occurs while importing the bank file using app 'Manage Incoming Payment Files'

Symptom

While importing the bank file using the app 'Manage Incoming Payment Files' below error occurs:

Error: House bank table: No entry with bank key XXXXXXXX and acct YYYYYYYYYYEUR

Environment

  • Financial Accounting (FI)
  • SAP S/4HANA Cloud
  • SAP Fiori

Reproducing the Issue

  1. Open the app 'Manage Incoming Payment Files'.
  2. Click on import and click on '+' to upload the files.
  3. Once the file is selected click on process.
  4. Status of the incoming payment file is 'ERROR'.
  5. Open the line to review the error message.         

Error: House bank table: No entry with bank key XXXXXXXX and acct YYYYYYYYYY
Diagnosis: The house bank tables (T012 and T012k) did not have ab entry with the bank key XXXXXXXX and acct YYYYYYYYYY.

Cause

Mismatch between the bank file and the bank account master data with respect to the account number

Resolution

The mismatch in leading zeros between the bank file and the bank account master data can be solved in two ways:

Solution A:

Remove/add leading zero of account number used in the file according to the requirement.

Solution B:

Create a new bank account with/without the leading zero to match the account number used in the file.

The steps to follow:

a. Open the old account  in ‘Manage Bank Accounts’ and edit it.
b. Click tab ‘House Bank Account Connectivity’.
c. Select the house bank account and click ‘Delete’.
d. Click ‘Save’ to save the changes.
e. Then create the bank account with/without leading zero again.

Keywords

FB736, FB 736,T012, T012K, Leading zeros, S4_PC, FIN-FSCM-CLM-BAM , KBA , FIN-FSCM-CLM-BAM , Bank Account Management , FIN-FSCM-CLM-BAM-2CL , Bank Account Management (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions