SAP Knowledge Base Article - Public

2868368 - Change of Column Width in C4C

Symptom

You are making changes to column width and changes are not reflected when you re-logon to system.

Environment

SAP Cloud For Customer

Reproducing the Issue

  • Go to the Customer work center as an example.
  • Click Accounts.
  • Increase column width.
  • Refresh screen or re-login
  • Changes are not saved.

Cause

The Company Setting "Enable Auto Adjustment of Table Column Width" is enabled.

Resolution

  1. Navigate to User Icon -> Settings.
  2. Open Company Settings.
  3. Ensure the Company Setting "Enable Auto Adjustment of Table Column Width" is NOT enabled.

Important Note: You need to also ensure that this setting is not enabled for the Business Role of the User you are testing with. As it will take precedence over the Company Wide Setting. So when completing the above steps, switch to the relevant Business Role and also make the change there if needed.

Keywords

change of column width, auto adjust column width, column width, column size, column resize, Fiori, Save, Cloud for Customer , KBA , AP-RC-UIF-FLX-FRW , UI Adaptation Framework , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions