Symptom
Expired employee's appointments cannot be found/ activities for employees with status obsolete cannot be searched.
Environment
SAP Cloud for customer
Reproducing the Issue
- Go to the Activities work centre.
- Go to the Appointments view.
- Open query All.
- Open the Advanced filter.
- Open the OVS for Owner ID.
- Open Advanced filter.
- For Status, reset the Exclude option.
- In Employee ID, enter the ID of an expired/ obsolete employee.
- Click Go.
Actual Result: no results.
Expected Result: the employee should be found.
Cause
The employee ovs shows internal employees and external employees (partner contacts/service agents).
For external employees it is possible to set the status (i.e. to obsolete) for internal employees the status is not exposed in C4C.
The default filter (with regards to status) in this ovs is "not equal obsolete" which excludes all external employees with status obsolete.
Additionally, we also have the query parameters valid from/valid to. They are not exposed in the advanced find form of the ovs, but you can influence these parameters with the ovs inport parameter "noValidityRestrictionIndicator".
The ovs will only show employees currently valid.
Resolution
After discussing with our Product Management, we have decided not to change the import parameter for this case, as this would effect all customers. Including those who prefer and are accustomed to the current behavior.
From a business case perspective, it makes sense to just show employees who are currently valid.
Keywords
KBA , LOD-CRM-ACT , Activities , Problem