SAP Knowledge Base Article - Public

2869664 - When Initiating a Call Via Click to Call The Live Activity Pop-Up Displays The Text Unknown Caller Instead of The Name

Symptom

When initiating a call via Click to Call, the Live Activity Pop-Up displays the Text Unknown Caller instead of the Name.

Environment

SAP Cloud for Customer - Service

Reproducing the Issue

Example: Employees

  1. Go to the People work center. 
  2. Select the Employees view. 
  3. Click on the Phone Hyperlink of Employee ABC (ABC represents the Employee ID)

The Live Activity Pop-up displays the Text Unknown Caller instead of the Name of the Employee.

Cause

Employees were not added to the Search Objects.

The same is valid if the issue happens for Individual Customers, Contacts, etc.

Resolution

To add Employees to the Search Object, please follow below Steps:

  1. Go to the Administrator work center.
  2. Select the Service and Social View. 
  3. Select the Live Activity Configuration Hyperlink. 
  4. Select the Add button in the Search Objects section.
  5. Add the Objects as required. 
  6. Save the changes. 

When you simulate a call now, you see that the correct name is displayed.

See Also

Help Documentation

Keywords

Live Activity Unknown Caller not recognized Click to Call , KBA , LOD-CRM-LA , Live Activity , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions