SAP Knowledge Base Article - Public

2870231 - Change field API visibility in a object - SuccessFactors Integrations

Symptom

The field is not returning any values in the query response or Integration Center. In Configure Object Definitions the field configuration is set as "Not Visible".

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SuccessFactors
    • Integrations
      • OData
      • Integration Center
    • Onboarding 

Cause

If the field is not set as "editable" the API will bring as null or blank in the response.

Resolution

1. Go to Configure Object Definitions

2. Select Object Definition and select the object

3. Click on Details for more information on the field configuration

4. If the visibility is set to "Not Visible" change to "Editable"

visibility.png

** If you receive the error message below it indicates that this is a standard field and cannot be changed. 

ConfigObjDef.png

On that case we recommend to submit an enhancement request to have this functionality considered within future development cycles – you can do this on our Customer Community Portal at http://community.successfactors.com/ or see KBA 2090228 - How to submit enhancement requests for SAP SuccessFactors

Keywords

API Visibility; configure object definitions; black value; API response; Integration Center; You are not allowed to change the value of attribute visibility for the field of this object; , KBA , LOD-SF-INT , Integrations , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-OBD , Onboarding , LOD-SF-INT-API , API & Adhoc API Framework , How To

Product

SAP SuccessFactors HCM Suite all versions