SAP Knowledge Base Article - Public

2870616 - Cannot Filter By Territory

Symptom

You have several objects, for example sales orders, in your system with an account that has a territory assigned.

When you go to the object OWL (for example Sales Orders view) and filter by that territory, you do not get any results.

Environment

SAP Cloud for Customer

Cause

You have multiple territories scoped and maintained for the account in question.

The sales orders created for the account do not have a territory assigned.

As there are no territories assigned for the orders, the search by territory won't return any result.

As per the Business Configuration question for territories:

the territory determination the system defaults to in a single territory approach is the account’s territory.

But for the account in the above scenario, there are two territories are assigned, hence the determination of territories does not happen for the particular account.

This is expected system behaviour for multi territory usage.

Resolution

Please make sure to run a realignment run, to set up territory rules or to manually assign territories in such scenarios.

Keywords

single territory, multiple territory, search by , KBA , LOD-LE-CQP-CO , Lean Sales Orders , LOD-CRM-TM , Territory Management , How To

Product

SAP Cloud for Customer core applications all versions