Symptom
You are working with Tickets and notices that when you change from any tab to the tab Activities, a save is triggered.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center.
- Select the Tickets view.
- Open Ticket ID XYZ (XYZ represents the Ticket ID).
- Change from the Overview tab to the Activities tab.
- See that there is a load on the screen and you can even see the save message for a while.
This might trigger workflow rules that have the conditions met and timing as "On Every Save".
Cause
When you open the Activities tab, there is a call to the Activities Business Object to check if any Tasks need to be assigned to the Ticket and this triggers a save.
Resolution
This is the current expected behavior of the system.
A possible option is to check the SAP Cloud for Customer Customer Influence to submit an idea:
Keywords
Workflow Rule ; Ticket ; Save ; Activities ; Trigger ; , KBA , LOD-CRM-SRP , Service Request Processing , How To
SAP Knowledge Base Article - Public