SAP Knowledge Base Article - Public

2870940 - Registered Products Query Cannot be Saved Without a Customer

Symptom

You are working with Contracts and is trying to add Covered Objects to it. When adding a Registered Product, you would like to save a custom query that would consider all Customers, however, system always default the same Customer to it, even if you remove the value and save.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Contracts work center.
  2. Open Contract ID XYZ (XYZ represents the Contract ID).
  3. Go to the Covered Objects tab.
  4. Click on Add and then click on the value help for Registered Product ID.
  5. Open the Advanced Search.
  6. See that Customer ID ABC (ABC represents the Customer ID) is already populated.
  7. Delete the information from the Customer field.
  8. Click on Save Query As.
  9. Save your query.
  10. The screen will refresh.
  11. Open the Query you just created, see that Customer ID ABC is still there.

Cause

The Customer field will always require a value.

Resolution

If you need to have a Query with no defined customer, you can add a "*" (asterisk) to the field and save the query.

  1. Go to the Contracts work center.
  2. Open Contract ID XYZ.
  3. Go to the Covered Objects tab.
  4. Click on Add and then click on the value help for Registered Product ID.
  5. Open the Advanced Search.
  6. See that Customer ID ABC is already populated.
  7. Delete the Customer ID ABC and replace it by "*".
  8. Click Save Query As.
  9. Save your query.
  10. The screen will refresh.
  11. Open the Query you just created, Customer field will show only "*".

Keywords

Contract ; Covered Objects ; Registered Products ; Customer ; Customer ID ; Query ; Save Query As ; Field ; Advanced Search ; , KBA , LOD-LE-COP , Contract Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions