SAP Knowledge Base Article - Public

2870989 - 'No items found' is shown when using the condition Postal Code in a workflow rule

Symptom

You have maintained a postal address for an account. Then, you create a workflow rule for the Accounts BO and try to use the Postal Code field as condition. However, you cannot select any postal code from the dropdown menu.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Accounts view.
  3. Open an account.
  4. Go to the Address facet.
  5. Maintain a postal code there.
  6. Click Save.


  7. Go to Administrator work center.
  8. Go to the Workflow Rules view.
  9. Click in New.
  10. Maintain:
    - Business Object: Account.
    - Timing: On Every Save.
  11. In the Define Condition section, click in Add Group.
  12. Maintain Field: Postal Code, Compare Operator: Contains, With: Value.
  13. In the last drop down field, it shows as 'No items found'.

    PostalCode_NoItemsFound.png

Cause

Postal Code cannot currently be used in workflow conditions.
 
Our development team has confirmed that they will try to make this possible in a future release. However, we still cannot make any commitment.

Resolution

If your scenario cannot be implemented via workflow, please either evaluate the PDI option or check if the territory realignment run can be scheduled more frequently.

Keywords

postal code, condition, workflow rule, realignment run, , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 1911