SAP Knowledge Base Article - Public

2871354 - Cannot Define Gender for Individual Customer.

Symptom

You want to restrict the selection for Gender field in Individual Customer, but there no item to define such setting under Business Configuration.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customer work center.
  2. Go to Individual Customer work center view.
  3. Click + to create a new Individual Customer,  or open any existing Individual Customer.
  4. Go to Overview tab, and navigate to standard field "Gender".
  5. There are 5 options in the drop-down list:
  • Male
  • Female
  • Gender not known
  • Gender not specified
  • Nonbinary

 

Question:

You would like to have only 2 or several options of the above dowp-down list, in order to avoid misunderstanding.

And you find Title and Academic could be defined under Business Configuration (Activity: General Business Partners), but there is no item to define Gender there.

 

Cause

This is the system standard behavior.

Due to legal requirements, we had to extend the Gender Code List.

Resolution

As a workaround, you can restrict the Gender display via Code List Restriction.

Steps:

  1. Go to Administrator work center.
  2. Go to General settings view and open Code List Restrictions.
  3. Check + to create a new rule with the following conditions:
  • Business Object: Account
  • Code to Restrict: Gender

 

PS: If you need to restrict the Code List for Contacts and Partner Contacts, please create Code List Restriction for Business Object “Contact / Partner / Competitor”.

Keywords

Gender;Individual Customer;General Business Partners; , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions