Symptom
When forwarding a candidate from a Job Requisition an error message appears on the screen stating that it is not possible due to the Privacy Settings.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
Option 1: From the applicants list
- Check the box right next to the candidate you want to forward -> Action -> Forward:
- Error message appears:
Option 2: From the specific application
- Open the applicant -> Take Action -> Place the mouse on top of the Forward option:
Cause
This is due to the privacy option selected by the candidate.
Resolution
If a candidate selects the most restrictive option "Only recruiters managing jobs I apply to" the candidate visibility will be restricted to that specific Job Requisition, the candidate cannot be forwarded or found in the candidate search. This behavior applies to all three methods of forwarding a candidate (Forward To Requisition, Forward To Colleague, Forward As Applicant).
To confirm that you can hover the padlock next to the applicant name and the system will show you which privacy option was selected by the candidate:
The candidates that have the padlock are candidates with restrictive privacy options selected in their candidate profiles.
It is possible to report on the candidates' privacy options. Please refer to the KBA 2871709 for more information.
For more information about Candidate Privacy Options, please see KBA 2213656.
Please note that with 1H 2023 it will be possible to forward candididates as applicants (Forward as Applicant feature) only from an Evergreen Job Requisition to one (or more) of its child Job Requisitions, regardless of the candidate privacy options.
Keywords
Candidate, privacy, options, error, message forward, alert, not, possible, enabled , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-APP , Applicants and Job Applications , How To