Symptom
It is not clear how are the Purchase Requisition attachments created on the App Create Purchase Requisition Advanced integrated in My Inbox.
Environment
S/4HANA Cloud
Reproducing the Issue
You upload an attachment at Header Level in the Purchase Requisition Advanced App and this Attachment is not visible in My inbox.
Cause
Header Attachments use the GOS technology
GOS is not integrated with My inbox App
Item attachments use DMS ( Document Management System ) , this kind of attachments are visible in My Inbox App
Resolution
If you create an attachment using the professional app , it will be assigned to the item , using DMS . This will be displayed in My Inbox.
If you want the same when the attachment is created in the advanced app, you have to choose the DMS and not the GOS technology.
• DMS attachments are visible in My inbox from 1808
• DMS are created on item level and they are visible in my inbox
These attachments are visible when the workflow is activated at item or header Level, so they are also visible with overall release.
See Also
Concept is that attachments in My Inbox are designed to work with the corresponding S/4HANA fiori apps. This means, you can only retrieve those type of attachments which you can upload in the fiori app. Since purchasing fiori apps support GOS attachments only, only these can be retrieved in My Inbox. You can overwrite this behaviour by creating an implementation in the BADI WF_OBJECT_ATTACHMENT.
Keywords
KBA , MM-FIO-PUR-REL , Fiori UI for Purchasing Approval , MM-PUR-PO , Purchase Orders , MM-PUR-REQ , Purchase Requisitions , MM-PUR-GF-WOF , Workflow , Problem