Symptom
Even though a workflow for Credit Memo Requests has been configured and activated, no approval is assigned to the document and no workflow is triggered.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Logon with User Role SAP_BR_INTERNAL_SALES_REP assigned.
- Open Manage Credit Memo Requests (F1989).
- Choose Create Credit Memo Request.
- Order Type: CR (Credit Memo Request).
- Enter the Credit Memo Request document data.
- Save the entries.
- Check if the document is awaiting approval.
Cause
The BAdI SD_APM_SET_APPROVAL_REASON has not been correctly implemented.
Resolution
Ensure that the salesdocapprovalreason is set on the BAdI implementation according to a condition, e.g. salesdocument-salesdocumentcategory = 'K'.
Without setting salesdocapprovalreason, the document will not be set into approval and then no workflow will be triggered.
See Also
Keywords
Manage Sales Document Workflows, Credit Memo Processing, 1EZ, F1989, SAP_SD_BC_CONFIGURE, manageApprovalWorkflow, SD_APM_SET_APPROVAL_REASON, credit memo request, CMR, approval, awaiting approval , KBA , SD-SLS-CMR-2CL , Credit Memo Request and Debit Memo Request (Public Cloud) , SD-SLS-2CL , Sales (Public Cloud) , Problem
SAP Knowledge Base Article - Public