Symptom
When users create requistiion using Browse "Families & Roles" they are getting the message Error "Unable to process your request. Please contact your configuration team for assistance".
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Create a Requisition
- Select a template
- Select Browse "Families & Roles" select Job Family
- Fill out the operators and click Next
- You'll get the message Error " Unable to process your request. Please contact your configuration team for assistance".
Cause
We have identified 3 root causes so far:
- Missing RBP Permissions for the affected users.
- Business rule linked on Initialize/Save trigger does not support some of the field changes.
- The user associated to the field in the creation screen is not part of the Recruiting Group associated to the operator field in the template.
Resolution
For Cause 1:
In most cases there are missing RBP Permissions for the user who creates the Requistion, please check the following RBP permission and make sure the users have the following permissions:
Manage Job & Skill Profile Visibility
JobReqProfile and make sure thay have the following Edit/Import/Export/View permissions.
For Cause 2:
One of the field mapping that can cause issue when creating job requisition via Browse "Families & Roles" is the field mapping that will require the system to check the position data to get the field from there. Position to Requisition integration can on only happen when creating a requisition in Position Org Chart or if the Position Object is defined in the job requisition template.
For Cause 3:
It will be required to either add the user to the Recruiting Group in question or to remove the Recruiting Group configuration of the field.
See Also
Keywords
Error, Create, Requisition, Families, Roles, Job, Profile, builder, role, code, oninit, onsave, onchange, creation, page, req, template. , KBA , LOD-SF-RCM-JOB , Job Postings & Requisitions , Problem