Symptom
There are two (or more) fields that its showing the same value for all of them in the Ad Hoc report Person and Employment As of Date and Date Range domains.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
- SAP SuccessFactors Employee Central
- Reporting Data
Reproducing the Issue
- Check the Employee Profile values:
Note: There is a value for Field 1 (Value 1) and another value for Field 2 (Value 2) in my given example above. - Go to Ad Hoc Report
- Create a new report under Person and Employment (As of Date) domain.
- Select the desired fields on the Columns.
Note: Above image already highlight a strange behavior in the selection of the columns fields. - After that choose the desired Filters
- Run the report
Result:
The value is the same for both fields results:
Cause
There are two different causes for this issue:
Cause 1:
You have defined two custom fields with the same source of data and the column using the same type will have the same logical column name irrespective of the label given in data model.
Check highlight the configuration in my example:
Cause 2:
A system limitation for custom fields where by the system has a max length which it can read for field identifier exists. This means if you have two custom field with similar names where the only difference exist at the end of the field ID. The Ad Hoc Report logic will truncate the id's and if the two fields now have the same truncated id the system will return the same label for both as it is unable to differentiate between the fields.
For example; two custom fields are defined with the following IDs:
- cust_org_field_level_1
- cust_org_field_level_2
The system will truncate both of these fields to cust_org_field and as the differator of number at the end will be removed, both fields will now have the same id. The system can then not differatie between the two fields and will use the same label for both.
Resolution
Cause 1:
Engineering team has confirmed that this is expected behavior as the source of the values is the same for both fields.
Since that you need to check your configuration along with your Implementation Partner to align your desired business behavior.
Cause 2:
This is a system limitation. It is recommend to use shorter field IDs. From the above example it would be recommend to use the following field ids instead to prevent this issue:
- cust_org1L
- cust_org2L
Keywords
duplicated,values,object,twice,results,ad hoc,source,data,issues, CS20200000516914 , KBA , LOD-SF-EC-REP , Reporting Data (EC core only) , Problem