SAP Knowledge Base Article - Public

2874898 - "Regret Termination" field value not appearing in Report - Employee Central

Symptom

When looking at an terminated employee you are able to see the Regret Termination is set to "No", however in the reports it is showing no value.

Environment

SAP SuccesssFactors Employee Central

Cause

Two possible causes identified for this behavior:

  1. The termination of the target employee was done via import and the Regret Termination field was not filled.
  2. When the termination was done via UI the field was left blank.

Note: The UI accept just "Yes" and "No" as value, so if the field was left blank the UI will automatically set to "No". In the other hand the data base accept "Null" as valid value then if the field was not filled with a value in the UI or import the data base will be "Null" and this is the value that reports will capture.

Resolution

To solve this inconvinience please re-import the Termination Details with the Regret Termination filled.

Keywords

regret, termination, report, null, no, ad-hoc, value, termination, employment, details, reports, , KBA , LOD-SF-EC-REP , Reporting Data (EC core only) , LOD-SF-EC-EMP , Employment Information (Employment Details) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions