Symptom
Some business records do not show up on search in Jam, even though they can be found from the Business Records section.
Examples-> LMS records(Items, Curricula), C4C records(Accounts, Opportunities) etc.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP Jam Collaboration
Reproducing the Issue
- Login to Jam and search for a Business Record from the top search bar.
- The record does not show up in search results->
Cause
The business record has not yet been accessed by any Jam user from the Business Records tab.
Hence, it has not been search indexed in Jam.
Resolution
In order to make any business record searchable in Jam, it needs to be accessed/opened by any Jam user from the Business Records tab. That is when the record will be indexed for search.
Let's take the example shown above, where the record being searched for is an Item, named "Test_Aug21".
Resolution Steps- >
- Access Business Records tab (Shown as Learning here)
- Click on Item
- Hover on the item in concern, "Test_Aug21", to bring up the pop-up menu with the Item details. Another option is to just click on the item and open it.
- Search for the item again from the top search bar, it will be shown in the result now.
Keywords
Search record,Search business record,search item,cannot search record,cannot search item , KBA , LOD-SF-JAM-SRH , Search , Problem