Symptom
No users are being synced with BizX environment. When checking in Site Maintenance Viewer, we see that Get Recruiters from ATS is :
- throwing an error message:
NullPointerException: while trying to invoke the method java.lang.Throwable.getMessage() of a null object returned from java.lang.Exception.getCause()
Or
RCM getRecruitersForRMK service could not be reached or is timing out: </error>
not showing an error but only showing the "Starting" message and not the "Finished" message, and therefore the log and its content is not visible
Environment
SAP SuccessFactors Recruiting Marketing
Cause
- There are too many users with the Recruiter RMK SSO Permission in BizX environment
and - All the users have the same email address.
Resolution
The solution for this issue would be:
- Review the permission roles given and configured, to make sure that only recruiters have the RMK permissions to limit the load on the sync process, as the permission role should not be applied to all users.
- Review the email address of the users you're trying to sync with RMK in the User Data File, in order to have them all with unique email addresses, as this is what Recruiting Marketing system uses as a reference to provide the users the access to Career Site Builder and the Recruiter permissions.
See Also
2430188 - While Accessing Manage Career Site Builder, Source Tracker or Advanced Analytics the System Redirects to the Home Page - Recruiting Marketing
Keywords
RMK, RCM, recruiter sync, Recruiter SSO Permission, users sync, BizX, Permission role, unique email , KBA , LOD-SF-RMK , Recruiting Marketing , LOD-SF-RMK-CC , Command Center , Problem