SAP Knowledge Base Article - Public

2875917 - Get Recruiters from ATS is throwing an error in Command Center or not showing as finished - Recruiting Marketing

Symptom

No users are being synced with BizX environment. When checking the Process logs in Command Center, we see that Get Recruiters from ATS is :

throwing an error message as listed below or not showing an error but only showing the "Starting" message and not the "Finished" message, and therefore the log and its content is not visible.

NullPointerException: while trying to invoke the method java.lang.Throwable.getMessage() of a null object returned from java.lang.Exception.getCause()

Or

RCM getRecruitersForRMK service could not be reached or is timing out: </error>

Environment

SAP SuccessFactors Recruiting Marketing

Cause

There are too many users with the Recruiter RMK SSO Permission in BizX environment

Resolution

Review the permission roles given and configured, to make sure that only recruiters have the RMK permissions to limit the load on the sync process, as the permission role should not be applied to all users.

See Also

2430188 - While Accessing Manage Career Site Builder, Source Tracker or Advanced Analytics the System Redirects to the Home Page - Recruiting Marketing

Keywords

RMK, RCM, recruiter sync, Recruiter SSO Permission, users sync, BizX, Permission role, unique email , KBA , LOD-SF-RMK , Recruiting Marketing , LOD-SF-RMK-CC , Command Center , Problem

Product

SAP SuccessFactors Recruiting all versions